Between 09:30 and 12:05 UTC on Tuesday, 9th December, an issue in the Swedish SEK clearing process affected a subset of payments. While 819 payments were marked failed and funds returned to Client balance, they were also successfully processed to beneficiaries.
Where failures have been re-submitted, please be assured you will only be debited once, with the original funds received under active recovery via our SEK Network Partner as part of the wider Swedish clearing scheme remediation efforts.
No further action required.
Posted Dec 12, 2025 - 10:22 UTC
Update
We are aware of an ongoing issue affecting a subset of SEK domestic payments submitted yesterday between 09:30 and 12:05. Our network partners are still working to fully resolve the problem.
Internal checks confirm that while most payments from this timeframe have now processed as expected, a portion were either delayed by one day or failed.
All other SEK payments continue to be processed normally.
We will continue to provide updates as more information becomes available.
Posted Dec 10, 2025 - 09:28 UTC
Monitoring
We are aware of an issue affecting domestic credit transfers in Sweden, which may cause delays to both incoming and outgoing SEK transactions.
Our network providers are actively investigating, and we will share updates as soon as more information becomes available.