Payment Validation Service Disruption (Resolved)

Incident Report for Currencycloud

Postmortem

Overview

On 1 July 2026, an issue was identified impacting payment validation services, resulting in intermittent 500 Internal Server Error responses during payment validation requests. The issue affected the payment validation flow across the service-sca, api-v2, and payments-engine services. Payments Core and Infrastructure teams investigated the issue and restored service by refreshing the affected cache and recycling the payments-engine pods. Following a period of monitoring with no further errors observed, the incident was formally resolved and services returned to normal operation.

Client Impact

During the incident, some clients may have experienced failures when attempting to validate payments, resulting in payment submissions being unsuccessful.

The impact was limited to payment validation requests returning intermittent errors. Following remediation activities, payment validation services recovered and customers were able to submit payments normally.

Root Cause

The issue was caused by unexpected behavior within the valid payments cache used by the payment validation service. The cache ceased returning the required data for payment validation requests, resulting in internal server errors within dependent services.

Service was restored after the Payments Core and Infrastructure teams refreshed the affected cache and recycled the payments-engine pods, allowing the payment validation flow to recover and resume normal processing.

Currencycloud Confidential
Posted Jul 08, 2026 - 12:47 UTC

Resolved

For awareness, earlier today we investigated an issue affecting payment validation services which may have caused some customers to experience errors when submitting or validating payments.

The issue was identified, recovery actions were completed, and all affected services have now been restored. Following the recycling of payment-engine pods and validation checks by engineering teams, normal processing resumed. The incident was formally resolved at 03:56 BST after confirmation that payment validation requests had recovered and error rates had ceased.

No further action is required from customers, and services are operating normally.
Posted Jul 02, 2026 - 08:53 UTC
This incident affected: Payments.