Some Customers Unable to View Beneficiary Information

Incident Report for Currencycloud

Resolved

The issue affecting the ability to view beneficiary information has now been resolved. Beneficiary details are loading normally and service stability has been confirmed through monitoring.

We apologize for the inconvenience caused and appreciate your patience while teams investigated and restored the service.
Posted Sep 01, 2026 - 16:15 UTC

Monitoring

We have implemented recovery actions and service functionality has been restored. Customers should once again be able to view beneficiary details and access records that were previously returning errors.

We are continuing to monitor the service to ensure stability while our teams complete their investigation into the underlying cause. We will provide a further update once issue is fully resolved.
Posted Sep 01, 2026 - 14:33 UTC

Investigating

We are investigating an issue affecting beneficiary details within Direct. As a result, some customers may be unable to view existing beneficiary information and may receive an error message when attempting to access beneficiary details.

Our teams are actively investigating and working to restore normal service. We will provide further updates as more information becomes available.
Posted Sep 01, 2026 - 13:36 UTC
This incident affected: Payments.