Incident Report - PLN Delayed Payments
Incident Report for Currencycloud
Postmortem

OVERVIEW

The PGP encryption key that is used to send and receive messages with our PLN local provider required renewal, prior to the expiry date of 31 August 2024. Delays in successful completion resulted in the renewal occurring on the next working day, 2 September 2024, post the PLN currency cut-off.

This delayed renewal resulted in 126 PLN payments value dated 2 September 2024 across 10 clients processing one day late.

ROOT CAUSE INVESTIGATION

Post the PLN currency cut-off on the last business day before the renewal, Friday 30 of August 2024, Currencycloud engaged with our local PLN provider to initiate renewal of the PGP encryption key that is used to send and receive messages.

Upon completion, customers received error messages notifying them that service problems were being encountered. Upon investigation, we identified the inclusion of a secondary control passphrase which required additional code changes to support.

The decision was taken to roll back to the previous encryption key and conclude the changes on the next working day. On 2 September 2024, the PGP encryption key renewal commenced, which included a detailed testing phase to ensure successful processing and was ultimately successful.

This fix was put into the Currencycloud Production environment; however, the additional actions resulted in the change window being exceeded, thus our local PLN provider was unable to complete the requested transactions within the usual timeframes.

The time to implement the renewal resulted in the passing of the PLN currency cut-off.

REMEDIATION

The PGP encryption key has now been successfully renewed with our local PLN provider. The 126 PLN payments value dated 2 September 2024 across 10 clients were processed one day late.

We have conducted a full process review, moving forward we propose that renewals will incorporate contingency timelines to allow for potential delays in completion so that there is no impact to clients.

Posted Sep 06, 2024 - 09:35 UTC

Resolved
This incident has been resolved.
Posted Sep 02, 2024 - 11:38 UTC
Investigating
We are investigating an issue that could cause delays to clients local PLN payments reaching the beneficiary.
Posted Sep 02, 2024 - 09:15 UTC
This incident affected: Payments.