EUR virtual account creation.

Incident Report for Currencycloud

Resolved

The incident has been resolved. A connector within our service had failed and did not re-establish connectivity. The connector is now running and further investigation to prevent re-occurrence will be carried out.
Posted Sep 05, 2026 - 05:13 UTC

Investigating

We are currently investigating an issue affecting the functionality to create EUR virtual accounts.
Posted Sep 05, 2026 - 02:15 UTC
This incident affected: Other.