Degraded Performance – EUR Payments via Direct Debit

Incident Report for Currencycloud

Resolved

The issue impacting EUR payments instructed via DIRECT has now been resolved.

All payment submissions and processing are operating normally.

We will continue to monitor closely.
Posted Jan 29, 2026 - 17:13 UTC

Investigating

We are currently investigating an issue impacting EUR payments instructed via DIRECT.

Some customers may experience delays or failures when submitting or processing these payments.
Posted Jan 29, 2026 - 15:41 UTC
This incident affected: Paydirect.io / Direct.