Issues Affecting Bulk Upload Payment Processing

Incident Report for Currencycloud

Postmortem

Overview

On July 2, 2026, we identified an issue affecting Bulk Upload payment processing. A subset of uploads did not result in the expected creation of payment entries and allocations.
Following investigation and corrective actions, Bulk Upload processing returned to normal and the incident was resolved on July 7, 2026.

Client Impact

A subset of customers using Bulk Upload functionality may have experienced uploads that did not result in the expected payment creation.

Following restoration of service, customers who experienced issues may wish to verify that all intended payment instructions were successfully submitted and processed.

Root Cause

A platform change affected the availability of payment validation data held in cache. In certain circumstances, this validation data was not available when Bulk Upload requests were processed.
As a result, some uploads were unable to complete validation as expected, preventing the creation of the associated payment entries and allocations. Changes were subsequently implemented to improve validation of cache refresh and distribution across platform instances.

Currencycloud Confidential
Posted Jul 08, 2026 - 12:46 UTC

Resolved

The issue affecting Bulk Upload payment processing has now been resolved. We apologise for the inconvenience caused and appreciate your patience while our teams investigated and restored the service.
Posted Jul 03, 2026 - 12:06 UTC

Update

We are continuing to investigate this issue.
Posted Jul 03, 2026 - 08:33 UTC

Investigating

We are currently investigating an issue affecting Bulk Upload payment processing. Some users may experience uploaded files successfully validating or completing processing, but the associated payments may not be created as expected.

Our engineering teams are actively working to identify the cause and restore normal service.

We apologise for any inconvenience and will provide further updates as more information becomes available.
Posted Jul 03, 2026 - 08:32 UTC
This incident affected: Payments.