Demo Environment Service Disruption

Incident Report for Currencycloud

Postmortem

Overview

On 14 September 2026, we experienced a disruption affecting one of our non-production demonstration environments. This impacted access to balances and related account functionality within the demonstration environments only. Service restoration activities began immediately after detection, and core functionality was restored the same day. Following additional validation and recovery activities, the incident was fully resolved on 15 September 2026.

Client Impact

A subset of users accessing the DEMO environment may have experienced limited visibility of balances and using certain associated features during the affected period. The disruption was limited to non-production demonstration services.

There was no impact to Currencycloud production services, client funds, payment processing, or live customer activity. No customer action was required.

Root Cause

The incident was caused by an unintended infrastructure configuration change within the DEMO environment. This resulted in the temporary unavailability of a component supporting balances and related functionality in the DEMO environment.

To restore service, our engineering teams rebuilt the affected database resources, re-established the required configuration, and validated functionality across the environment. Additional reviews were completed to confirm that production systems and other environments were not affected.

Corrective actions have been identified and are being tracked to strengthen infrastructure controls and reduce the likelihood of similar incidents occurring in the future. Following successful restoration and validation, the DEMO environment returned to normal operation.

Currencycloud Confidential

Posted Sep 15, 2026 - 15:39 UTC

Resolved

The issue affecting one of our non-production demonstration environments has now been fully resolved, and services have returned to normal operation.

The disruption was limited to the demo environment only. There was no impact to Currencycloud production services, client funds, payment processing, or live customer activity at any point during the incident.

Following remediation and validation activities, the affected demo services have been restored and are operating as expected. We will continue to monitor the environment as part of normal operational oversight.
Posted Sep 14, 2026 - 14:46 UTC

Investigating

We are currently investigating an issue affecting one of our non-production demonstration environments.

The issue is impacting access to and functionality within the demo environment only.

There is no impact to Currencycloud production services, client funds, payment processing, or live customer activity. All production systems remain fully operational.

Our teams are actively working to restore the affected demo environment, and we will continue to monitor progress until service has been fully recovered.
Posted Sep 14, 2026 - 13:29 UTC
This incident affected: Other.