Delays in Funding Processing

Incident Report for Currencycloud

Resolved

The delays in funding processing have been resolved.

Normal processing times have been fully restored, and all systems are operating as expected.

If you continue to experience any issues, please contact our support team.
Posted Dec 11, 2025 - 13:30 UTC

Investigating

We are investigating an issue causing delays in funding processing.

Our team is working to reduce the backlog and restore normal processing as soon as possible.
Posted Dec 11, 2025 - 12:06 UTC
This incident affected: Balances.