Issues Affecting Bulk Upload Payment Processing

Incident Report for Currencycloud

Postmortem

Overview

On July 2, 2026, we identified an issue affecting Bulk Upload payment processing. A subset of uploads did not result in the expected creation of payment entries and allocations.
Following investigation and corrective actions, Bulk Upload processing returned to normal and the incident was resolved on July 7, 2026.

Client Impact

A subset of customers using Bulk Upload functionality may have experienced uploads that did not result in the expected payment creation.

Following restoration of service, customers who experienced issues may wish to verify that all intended payment instructions were successfully submitted and processed.

Root Cause

A platform change affected the availability of payment validation data held in cache. In certain circumstances, this validation data was not available when Bulk Upload requests were processed.
As a result, some uploads were unable to complete validation as expected, preventing the creation of the associated payment entries and allocations. Changes were subsequently implemented to improve validation of cache refresh and distribution across platform instances.

Currencycloud Confidential
Posted Jul 08, 2026 - 12:46 UTC

Resolved

A fix has been implemented and Bulk Upload payment processing is operating normally. We have seen no further reports of the issue since the remediation was applied and are continuing to monitor the service closely.

We apologise for the disruption caused and thank you for your patience while we investigated and resolved the issue.
Posted Jul 07, 2026 - 15:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 07, 2026 - 10:59 UTC

Investigating

We are aware of a small number of continued reports relating to Bulk Upload payment processing following the implementation of our initial fix. While the majority of Bulk Upload requests are processing successfully, we are investigating whether a subset of requests may still be affected under certain conditions.

Our engineering teams are actively reviewing the recent reports and monitoring platform performance to determine whether any further corrective action is required.
We apologise for the continued disruption and will provide further updates as soon as additional information becomes available.
Posted Jul 06, 2026 - 12:59 UTC
This incident affected: Payments.