Delay in Virtual Account Creation.

Incident Report for Currencycloud

Resolved

All missing Virtual Accounts have been created
Posted Dec 11, 2025 - 11:03 UTC

Investigating

We are investigating an issue that is impacting some Virtual Account creations.

Team is working to resolve the missing Virtual accounts as soon as possible.
Posted Dec 11, 2025 - 10:04 UTC
This incident affected: Other.